linux登录时候提示字符集有问题解决方法

互联网老兵互联网老兵 2023-07-17 131 阅读

字符集报错一直存在

locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory

背景

公司有台jenkins服务器,因历史原因一直使用centos6.5,突然登录时候提示字符集有问题,本人其实已经使用centos7很久,没碰到过这样问题,排查过程也一脸懵逼。

就是各种字符集报错,设置无效,n天后经过不断排查,发现为glibc导致,拍错过程还发现不能使用2.15版本,我擦,赶紧记一下。

排错过程

1.直接反应为字符集,百度查了多个文档,各种配置,各种更新插件,就是不生效,再赶上手头还有其他工作,也耽误了几天。

今天仔细想了一下,既然任何字符集都不生效,应该不是字符集问题,肯定加载过程出问题了,但是这几天服务器没做啥工作啊,无聊翻了下百度,突然看到了glibc的相关帖子,然后继续百度搜了一下,还真有别的哥们碰到过类似的,说编译时候要加make localedata/install-locales,了解办法后赶紧尝试。

2.系统默认是2.12,我因为有的插件需求,我升级到了2.14。我本想降到2.12,但是又一想,不如下载个2.15,重新编译,理论应该就都解决了。

3.网上找glibc-2.15资源,下载,编译,安装,常规操作后,将/lib64/libc.so.6软链接指向glibc-2.15,然后就又报错了 Illegal instruction (core dumped),系统也无法登陆了,赶紧修复 LD_PRELOAD=/lib64/libc-2.12.so ln -sf /lib64/libc-2.12.so /lib64/libc.so.6 先降会2.12,起码字符集故障解决了,但是这样不行啊,经过多次尝试升级2.15,最终还是失败了,网上也没找到相关解决办法。

4.无奈,想是不是和系统兼容问题,不放弃,又尝试升级2.17,依然常规操作,这次终于可以了。。。

具体过程

1.查看系统glibc版本库

strings /lib64/libc.so.6 |grep GLIBC_

linux登录时候提示字符集有问题解决方法

发现最高到2.12,准备升级到2.17,一定不要装2.15,我不知道是不是我自己有问题,反正我装不上

2.下载安装

进入下载目录/data/install,执行命令,具体不解释了,都懂

wget https://ftp.gnu.org/gnu/glibc/glibc-2.17.tar.gz
tar xvf glibc-2.17.tar.gz
mkdir glibc-build-2.17
cd glibc-build-2.17/
../glibc-2.17/configure --prefix=/usr --disable-profile --enable-add-ons --with-headers=/usr/include --with-binutils=/usr/bin
make -j8 && make install && make localedata/install-locales

3.验证

strings /lib64/libc.so.6 | grep GLIBC

linux登录时候提示字符集有问题解决方法

都不用替换/lib64/libc.so.6文件,而且文件软链接已指向glibc-2.17,完事了。

以上所述是小编给大家介绍的linux登录时候提示字符集有问题解决方法,希望对大家有所帮助,如果大家有任何疑问请给我留言,小编会及时回复大家的。在此也非常感谢大家对17站长网的支持!

The End 微信扫一扫

文章声明:本网站发布的内容(图片、视频和文字)以用户投稿、转载内容为主,如果涉及侵权请尽快告知,我们将会在第一时间删除。文章观点不代表本网站立场,如需处理请联系客服。邮箱:info@xzpmsj.com。

上一篇 下一篇
取消
微信二维码
微信二维码
支付宝二维码